Jump to content


Photo

V18.0n

Download Software Update Animation Master Get it now!

  • Please log in to reply
48 replies to this topic

#1 Jason Simonds

Jason Simonds

    Prolific

  • Admin
  • PipPipPipPipPipPipPip
  • 903 posts
  • Jason Simonds
  • *Admin*
  • Vancouver, WA
  • v18
  • Windows
  • Programmer:enough to be hazardous

Posted 22 September 2015 - 08:55 PM

Installers:

Change Log

  • New All:
      - 6627:  Very slow rendering on select frames
  • New All:
      - 6624:  "Paste with Bones" over-simplifies CP Weights
  • New All:
      - 6621:  Expressions no longer possible
  • New All:
      - 6616:  2-axis Translate handles not drawn properly
  • New OSX
    psd and tif imageformat plugins added
  • New All:
    psd files are corrupted if they have a alphachannel
  • Changed All
    tif imageformat plugin, added compression dialog avaible compression types None,Packbits,LZW,Zip default is LZW
  • New All:
      - 6611:  "Apply Snapshot" not available in Pose Window
    • changed "Apply Snapshot"
    • applied snapshot now correct scaled , if a value <> 1 is used for the created decalimage
    • possible to input the value for scaling numerical
  • New All:
    "Remove All CP Weights" has reassigned some cp's to the false bone
  • New All
      - 6623:  Plugin "Clone CP Weights" clone the weights from one model to another model , the target must be identical to the source model (bones,cp's) except the cp weights and cp bone assignments
  • New All:
    crash in AMXtex plugin , when export animations


#2 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 22 September 2015 - 09:15 PM

Jason,

The 64bit installer works fine but with the 32bit installer I get a classroom server IP dialogue...

Attached Thumbnails

  • classroom installer.png

A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#3 Jason Simonds

Jason Simonds

    Prolific

  • Admin
  • PipPipPipPipPipPipPip
  • 903 posts
  • Jason Simonds
  • *Admin*
  • Vancouver, WA
  • v18
  • Windows
  • Programmer:enough to be hazardous

Posted 22 September 2015 - 09:24 PM

Hmmm,

It seams to work for me
https://www.hash.com...ws/AM_32BIT.exe

Does it now work for you?

#4 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 22 September 2015 - 09:58 PM

Same error/dialogue box here.

Perhaps it is Windows 10 related?

 

(Note that I tried installing in a variety of ways... to include a clean install in its own directory.  I've never seen the classroom dialogue before so my first impression was that the installer was for schools etc. that run A:M on a distro'd network)

 

Upon canceling the classroom server dialogue I get a license server cancellation error:

 

Disclaimer:  This is definitely not a showstopper for me personally as I run the 64bit release almost exclusively.

 

 

 

Attached Thumbnails

  • license server dialogue canx.png

A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#5 itsjustme

itsjustme

    David Simmons......me.

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5387 posts
  • David Simmons
  • v18
  • Windows

Posted 22 September 2015 - 10:11 PM

Thanks!  A very helpful set of updates!



#6 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 22 September 2015 - 10:20 PM

Thanks!  A very helpful set of updates!

 

Does that mean 32bit installs correctly for you David?


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#7 itsjustme

itsjustme

    David Simmons......me.

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5387 posts
  • David Simmons
  • v18
  • Windows

Posted 22 September 2015 - 11:08 PM

 

Thanks!  A very helpful set of updates!

 

Does that mean 32bit installs correctly for you David?

 

 

No sir, the 32bit version won't install because it says it's not for my system...I never get as far as you did.

 

The 64bit version works fine though (in what I have tested so far).



#8 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 22 September 2015 - 11:19 PM

the 32bit version won't install because it says it's not for my system...I never get as far as you did.

 

That's very odd.  We should troubleshoot that because the 32bit release should work for you.

While the primary reason would be so that you can use A:M with features not available via 64bit the real underlying reason is to make sure Steffen's hard work maintaining both releases isn't for naught.  At the point where no one is using 32bit there's no reason to keep that going.  Don't anyone panic though... there is lots of life still left in 32bit.   :)

 

For my part, I've never had any issues running 32bit and 64bit together on the same computer.

 

Thanks for the confirmation.


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#9 itsjustme

itsjustme

    David Simmons......me.

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5387 posts
  • David Simmons
  • v18
  • Windows

Posted 22 September 2015 - 11:28 PM

I spoke too soon...I'm having trouble with the rotate manipulators.  I'll send a report.



#10 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 22 September 2015 - 11:40 PM

.I'm having trouble with the rotate manipulators.  I'll send a report.

 

This may relate to a problem I'm seeing.  When I select anything the focus doesn't stay with the selection.

The first instance I ran into (should be repeatable) is to select a group of CPs and try to Right Click to name/rename the group.  I can't right click unless very specifically targeting the edges of the selection.  I'll post a video here.

 

I'll assume at this point it may relate to WIn10 so folks may want to delay updating until confirmed.

 

I'll post a video of what I'm seeing..


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#11 itsjustme

itsjustme

    David Simmons......me.

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5387 posts
  • David Simmons
  • v18
  • Windows

Posted 22 September 2015 - 11:42 PM

The 32bit version now installs for me...the rotate manipulator problem is there as well.  I made a report.



#12 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 22 September 2015 - 11:54 PM

I was going to add my video to your report but I see it relates to Bones/Rigging which isn't what I'm having issues with.

I'll post the video here because if everyone else is seeing this it won't need a report... it'll be very obvious what isn't working.

I am wondering if this is primarily a Win 10 thing.

I'll ferret around and see if it doesn't have something to do with graphics settings.

I reset A:M to the defaults after a clean install.

 

I've attached a very rough screen capture of what I'm experiencing.

 

Aside:  This makes me glad I installed into a new directory (v18n) and still have v18m running properly.   :)

 

Edit:  One thing I haven't yet done.... I should restart my computer to make sure I've cleared out all of the cobwebs.

Update: No change after restart.  I can confirm that v18m still works though so for now it's back to that.

Attached Files


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#13 itsjustme

itsjustme

    David Simmons......me.

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5387 posts
  • David Simmons
  • v18
  • Windows

Posted 23 September 2015 - 12:28 AM

I was going to add my video to your report but I see it relates to Bones/Rigging which isn't what I'm having issues with.

I'll post the video here because if everyone else is seeing this it won't need a report... it'll be very obvious what isn't working.

I am wondering if this is primarily a Win 10 thing.

I'll ferret around and see if it doesn't have something to do with graphics settings.

I reset A:M to the defaults after a clean install.

 

I've attached a very rough screen capture of what I'm experiencing.

 

Aside:  This makes me glad I installed into a new directory (v18n) and still have v18m running properly.   :)

 

Edit:  One thing I haven't yet done.... I should restart my computer to make sure I've cleared out all of the cobwebs.

Update: No change after restart.  I can confirm that v18m still works though so for now it's back to that.

 

I'm having the same issue on Windows 8.1 with onboard graphics in both 32bit and 64bit versions.



#14 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 23 September 2015 - 12:42 AM

In the meantime I'm still exploring v18n,,, things like the ability to apply snapshot/screenshot within a pose will definitely be useful.

For those that were experiencing slow renders on certain frames v18n still addresses that issue.


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#15 itsjustme

itsjustme

    David Simmons......me.

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5387 posts
  • David Simmons
  • v18
  • Windows

Posted 23 September 2015 - 01:07 AM

In the meantime I'm still exploring v18n,,, things like the ability to apply snapshot/screenshot within a pose will definitely be useful.

For those that were experiencing slow renders on certain frames v18n still addresses that issue.

 

For me, it's the fix for "Paste with Bones" and the addition of the "Clone CP Weights" plugin.  The combination of those two make updating rigs and changing rigs a lot easier.



#16 yoda64

yoda64

    Prolific

  • Developer
  • PipPipPipPipPipPipPip
  • 726 posts
  • Steffen Gross
  • Goeppingen,Germany
  • Windows
  • Programmer:Yes

Posted 23 September 2015 - 11:38 AM

I'm looking into the bug , but I'm not sure if I can fix it fast , because I'm going at saturday in my planned holidays (without computers ...), and after fixing it takes around one day to recompile all versions .

It's look like only the windows versions are affectet , it can be, thats the cause is a compiler switch (Intel2015 to Intel 2016)


Kind Regards
Steffen

http://www.sgross.com/plugins/


#17 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 23 September 2015 - 01:35 PM

Don't sweat it Steffen. v18n can wait until you return from your vacation.
We primarily just need to make sure folks don't upgrade to a broken v18n without a means to retro back to v18m (which currently is not possible unless they've previously downloaded v18m because it cannot be found on the ftp site).

Bottom line: Enjoy your vacation. :)
A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#18 Jason Simonds

Jason Simonds

    Prolific

  • Admin
  • PipPipPipPipPipPipPip
  • 903 posts
  • Jason Simonds
  • *Admin*
  • Vancouver, WA
  • v18
  • Windows
  • Programmer:enough to be hazardous

Posted 23 September 2015 - 08:24 PM

Same error/dialogue box here.
Perhaps it is Windows 10 related?
 
(Note that I tried installing in a variety of ways... to include a clean install in its own directory.  I've never seen the classroom dialogue before so my first impression was that the installer was for schools etc. that run A:M on a distro'd network)
 
Upon canceling the classroom server dialogue I get a license server cancellation error:
 
Disclaimer:  This is definitely not a showstopper for me personally as I run the 64bit release almost exclusively.


I can not repeat this in windows 10

Here is the links to v18.0m
https://www.hash.com.../AM_32BIT_m.exe
https://www.hash.com.../AM_64BIT_m.exe

#19 Jason Simonds

Jason Simonds

    Prolific

  • Admin
  • PipPipPipPipPipPipPip
  • 903 posts
  • Jason Simonds
  • *Admin*
  • Vancouver, WA
  • v18
  • Windows
  • Programmer:enough to be hazardous

Posted 23 September 2015 - 08:35 PM

Try this link to AM32bit maybe it is a cache issue since I can not repeat it at all even in windows 10. I did re upload it in the main link too this time not threw ftp to see if that fixes it for you.
https://owncloud.has...UXtNzLhyfhBXok7

#20 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 24 September 2015 - 02:42 AM

Same Classroom License error here for v1832bit_M.
I downloaded and installed twice from your owncloud link just to make sure I wasn't messing up the download somehow.
I then installed to a clean directory each time.
No dice.

If anyone else has installed v1832bit_N successfully... without the classroom license dialog popping up... please let us know.
If everyone else is operational that would suggest something on my end. In the meantime I must assume those who purchase A:M for their classrooms (network license) should rightly expect to see this dialog.
A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#21 Jason Simonds

Jason Simonds

    Prolific

  • Admin
  • PipPipPipPipPipPipPip
  • 903 posts
  • Jason Simonds
  • *Admin*
  • Vancouver, WA
  • v18
  • Windows
  • Programmer:enough to be hazardous

Posted 24 September 2015 - 07:21 AM

Same Classroom License error here for v1832bit_N from your owncloud.  
I downloaded and installed twice from your owncloud link just to make sure I wasn't messing up the download somehow.
I then installed to a clean directory each time.
No dice.

If anyone else has installed v1832bit_N successfully... without the classroom license dialog popping up... please let us know.
If everyone else is operational that would suggest something on my end. In the meantime I must assume those who purchase A:M for their classrooms (network license) should rightly expect to see this dialog.


Does v18.0m work for you?
https://www.hash.com.../AM_32BIT_m.exe

or do you get the same error?

#22 robcat2075

robcat2075

    occasional smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 23196 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • v18
  • Windows
  • Programmer:NO

Posted 24 September 2015 - 07:43 AM

I'll note that I installed both the v18n 64 and 32-bit versions and they both seem to launch and run without reporting an error.

 

I'm on 64-bit Windows 7.


Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
Enter the 2017 Summer Memories Image Contest

this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!


#23 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 24 September 2015 - 07:57 AM

Does v18.0m work for you?
https://www.hash.com.../AM_32BIT_m.exe

or do you get the same error? 

Sorry, I think a typo crept in there. M and N or too similar!

Yes, both 64bit and 32bit versions of v18M are reportedly working fine (and working fine on my system too).
The issue there was that the version M files could not be found on the ftp site, which is now resolved:
I reported both releases of M working in the other topic:
 
Ref:  https://www.hash.com...showtopic=47314
 
The two outstanding issues appear to be:
v1832bit_M Issue:  classroom license/network connection dialog
v1864bit_M Issue:  selection of splines/objects not maintained
Report#6629 has been filed by David Simmons that likely relates to this second (64bit) issue but is observed with selection/manipulation of Bones.

He states in his report he is operating Win8.1.  Tore confirmed that he couldn't use v18M because he couldn't select/move anything.
 
As far as I can tell these issues are observed on Win10 systems and not yet confirmed as occurring on any other. 
Steffen thinks the selection issue might be due to change in compilers.


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#24 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 24 September 2015 - 08:39 AM

I'll note that I installed both the v18n 64 and 32-bit versions and they both seem to launch and run without reporting an error.

 

I'm on 64-bit Windows 7.

 

Robert,

Did you download and install from the official release or from previous download?  (or alternatively from Jason's posted owncloud file)

The 32bit is definitely trying to initiate a classroom/network license connection for me.

I don't see how that would happen short of using a different installer.

As of this moment I appear to be the only one with this classroom licensing issue on v1832bit_N.


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#25 robcat2075

robcat2075

    occasional smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 23196 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • v18
  • Windows
  • Programmer:NO

Posted 24 September 2015 - 10:16 AM

 

I'll note that I installed both the v18n 64 and 32-bit versions and they both seem to launch and run without reporting an error.

 

I'm on 64-bit Windows 7.

 

Robert,

Did you download and install from the official release or from previous download?  (or alternatively from Jason's posted owncloud file)

 

 

I downloaded what is linked to at the top of the thread... that's official, right?


Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
Enter the 2017 Summer Memories Image Contest

this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!


#26 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 24 September 2015 - 02:12 PM

I downloaded what is linked to at the top of the thread... that's official, right?

 

If you hafta ask...  ;)

 

It sounds like you downloaded and installed the right thing.


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#27 Jason Simonds

Jason Simonds

    Prolific

  • Admin
  • PipPipPipPipPipPipPip
  • 903 posts
  • Jason Simonds
  • *Admin*
  • Vancouver, WA
  • v18
  • Windows
  • Programmer:enough to be hazardous

Posted 27 September 2015 - 07:38 PM

v18.0n is back try it out!!!!1



#28 itsjustme

itsjustme

    David Simmons......me.

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5387 posts
  • David Simmons
  • v18
  • Windows

Posted 27 September 2015 - 11:09 PM

The rotate manipulator and mesh selection problems appear to have been fixed in the latest v18.0n in both the 64bit and 32bit versions.  When I have more time, I'll do more testing.  Thanks!



#29 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 28 September 2015 - 04:34 AM

Oh yeah... working great here.

Thanks!

 

Edit:  I should have explicitly stated that both 64bit and 32bit are working great.  


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#30 cribbidaj

cribbidaj

    Wayfarer

  • Craftsman/Mentor
  • PipPipPipPipPip
  • 275 posts
  • Chris Walters
  • Nashville, TN
  • current
  • Mac/Win

Posted 01 November 2015 - 06:05 AM

I am running A:M 18n (SSE 4) on a 2014 Macbook Pro Mavericks OS 10.9 computer.  In the options/modeling/lathe cross sections dialog box a string of numbers beginning with 2 has appeared and when I try to replace the number with an whole number an error message appears requesting I enter an integer between 1 and 100 (which I tried to do), then A:M crashes.

 

I have restarted A;M and/or my computer a number of times but the problem persists.  I have even reinstalled the latest version of A:M to no avail.

 

Please advise.



#31 Fuchur

Fuchur

    PatchWorker

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4857 posts
  • Gerald Zum Gahr
  • Karlsruhe, Germany
  • current
  • Windows

Posted 01 November 2015 - 07:08 AM

You may want to try to reset A:M ("Help > Reset Settings"), just in case... (in general this is not very usual to be the problem if you just recently installed, but who knows...)

 

See you

*Fuchur*


"I know, that I don't know."
See my projects, tutorials, reviews and join the German Animation:Master-Community at
www.PatchWork3d.de

Name: Gerald Zum Gahr, alias Fuchur
What stands "Fuchur" for?

Do want to see my favorite A:M-images?
Best of A:M collected by Gerald Zum Gahr

Searching for a *.X-Exporter(DirectX) or a *.dts-Exporter(Torque) for A:M?
Exporter Page

And how can I export to *.FBX-files or other 3d- / game-engines?
FBX-Pipeline to Unity3d / DirectX-Pipeline to Quest3d

Need more converters? *.obj OBJ), *.lwo , *.act or *.dxf ?
Arthur Walaseks' Exporters

Searching for great and free plugins?
www.sgross.com by Steffen Gross

You are searching for tutorials? More video- and text-tutorials can be found here:
Tutorial section of PW3d

You want to make your own video tutorial?
Recommended Tools and Step By Step Instructions

"R M B" stands for "Right Mouse Button"!

#32 cribbidaj

cribbidaj

    Wayfarer

  • Craftsman/Mentor
  • PipPipPipPipPip
  • 275 posts
  • Chris Walters
  • Nashville, TN
  • current
  • Mac/Win

Posted 01 November 2015 - 01:27 PM

I just reset my settings, but the problem persists.  In any window of the "option" settings, a random integer appears in the box.  Here's a screenshot showing the "undo" function with a random number in it.  Whenever I try to exit the options menu, A:M crashes after informing me to enter an integer between x and x.

Attached Thumbnails

  • Screen Shot 2015-11-01 at 3.22.06 PM.png


#33 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 01 November 2015 - 01:39 PM

I take it checking 'unlimited' doesn't work?

 

I wonder if this has anything to do with the 'finder' issue experienced on the Mac in ages past.

Since you are booting to Windows I'd guess not.

(Wait a sec... your post says Mavericks so I might be getting that wrong.

 

Try the number 20... just in case.

I think that is the default.


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#34 cribbidaj

cribbidaj

    Wayfarer

  • Craftsman/Mentor
  • PipPipPipPipPip
  • 275 posts
  • Chris Walters
  • Nashville, TN
  • current
  • Mac/Win

Posted 02 November 2015 - 06:49 AM

I'm able to enter the number 20 in the "undo" box and exit the options window without A:M crashing, but when I enter the options again the string of numbers appears, again in the "undo" box.  A:M crashes when I select the "unlimited" box, after an error message appears saying "Please enter an integer between 1 and 3200".  When I try to change the number of lathe cross sections from the random string of numbers to a different number, say 4 or 8, the error message "Please enter an integer between 1 and 3200" appears and A:M crashes.

 

Yes, I am using A:M on a Macbook Pro in Mavericks OS 10.9



#35 Rodney

Rodney

    A:M Bot 14309

  • Admin
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 6572 posts
  • Rodney Baker
  • *Admin*
  • Illinois (not Japan)
  • subscriber
  • Windows

Posted 02 November 2015 - 07:39 AM

I'm able to enter the number 20 in the "undo" box and exit the options window without A:M crashing,

 

 

This whole issue is of course repeatable so it perfect for a bug report.

One question though... 

 

In what way does this bug effect use of A:M?

Is there any effect outside of the issue going on behind the scenes with the random number?

Can you still undo anything?

More importantly does it effect anything else?

 

Also, while testing I would uncheck anything that is normally not checked, such as limiting redraws, etc.

It's important to start from the normal settings and those checkmarks seen in your screenshot are usually not checked by default.


A good idea is a seed, not a solution
See my effort to think about the art of animation at: My Blog
Want to learn A:M? Start TaoA:M

#36 cribbidaj

cribbidaj

    Wayfarer

  • Craftsman/Mentor
  • PipPipPipPipPip
  • 275 posts
  • Chris Walters
  • Nashville, TN
  • current
  • Mac/Win

Posted 02 November 2015 - 10:56 AM

I tried unchecking the boxes - the error message about entering integers appears once I tried to close the options window and then A:M crashed.

 

This does not effect my use of A:M.  I'm still able to work within all the windows - model, choreography, render, etc. - I am just unable to change options without receiving the error message and A:M crashing.  While modeling, the lathe tool still works as 4 cross sections (as I last successfully had it set) even though in the options dialog box the number is the random string starting with 20 . . .



#37 NancyGormezano

NancyGormezano

    Runs With Scissors

  • Film
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7686 posts
  • Nancy Gormezano
  • Cupertino, CA
  • Windows
  • Contests Won:**

Posted 02 November 2015 - 11:10 AM

This does not effect my use of A:M.  I'm still able to work within all the windows - model, choreography, render, etc. - I am just unable to change options without receiving the error message and A:M crashing.  While modeling, the lathe tool still works as 4 cross sections (as I last successfully had it set) even though in the options dialog box the number is the random string starting with 20 . . .

I would guess that not being able to change the lathe cross sections from 4 would eventually impact your use of A:M.

 

Have you tried changing your real-time driver? I notice it says Opengl3. Did you try option for opengl?



#38 cribbidaj

cribbidaj

    Wayfarer

  • Craftsman/Mentor
  • PipPipPipPipPip
  • 275 posts
  • Chris Walters
  • Nashville, TN
  • current
  • Mac/Win

Posted 02 November 2015 - 11:40 AM

Hi Nancy -

 

I just chose OpenGL over OpenGL3 and the crash still persists.



#39 Fuchur

Fuchur

    PatchWorker

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4857 posts
  • Gerald Zum Gahr
  • Karlsruhe, Germany
  • current
  • Windows

Posted 02 November 2015 - 12:21 PM

you could set such things using the registery but that is not very fluid...
"I know, that I don't know."
See my projects, tutorials, reviews and join the German Animation:Master-Community at
www.PatchWork3d.de

Name: Gerald Zum Gahr, alias Fuchur
What stands "Fuchur" for?

Do want to see my favorite A:M-images?
Best of A:M collected by Gerald Zum Gahr

Searching for a *.X-Exporter(DirectX) or a *.dts-Exporter(Torque) for A:M?
Exporter Page

And how can I export to *.FBX-files or other 3d- / game-engines?
FBX-Pipeline to Unity3d / DirectX-Pipeline to Quest3d

Need more converters? *.obj OBJ), *.lwo , *.act or *.dxf ?
Arthur Walaseks' Exporters

Searching for great and free plugins?
www.sgross.com by Steffen Gross

You are searching for tutorials? More video- and text-tutorials can be found here:
Tutorial section of PW3d

You want to make your own video tutorial?
Recommended Tools and Step By Step Instructions

"R M B" stands for "Right Mouse Button"!

#40 cribbidaj

cribbidaj

    Wayfarer

  • Craftsman/Mentor
  • PipPipPipPipPip
  • 275 posts
  • Chris Walters
  • Nashville, TN
  • current
  • Mac/Win

Posted 02 November 2015 - 12:52 PM

I will say that this anomaly occurred, as far as I know, after I updated my system via Apple's App Store a few days ago.  I hadn't used A:M in a few weeks before I updated the system software, so I'm not sure, but it could be something conflicting with the update.  None of my other software is showing strange behavior, only A:M, so I'm at a loss here.  If I could be sure it was the update that affected A:Ms parameters I'd let you know . . .

 

What do I do to submit this in a bug report for future release?



#41 Fuchur

Fuchur

    PatchWorker

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4857 posts
  • Gerald Zum Gahr
  • Karlsruhe, Germany
  • current
  • Windows

Posted 02 November 2015 - 12:57 PM

Go to hash.com/reports, register (it is not the same as on the forums) and insert your bug-report into the system there.

 

See you

*Fuchur*


"I know, that I don't know."
See my projects, tutorials, reviews and join the German Animation:Master-Community at
www.PatchWork3d.de

Name: Gerald Zum Gahr, alias Fuchur
What stands "Fuchur" for?

Do want to see my favorite A:M-images?
Best of A:M collected by Gerald Zum Gahr

Searching for a *.X-Exporter(DirectX) or a *.dts-Exporter(Torque) for A:M?
Exporter Page

And how can I export to *.FBX-files or other 3d- / game-engines?
FBX-Pipeline to Unity3d / DirectX-Pipeline to Quest3d

Need more converters? *.obj OBJ), *.lwo , *.act or *.dxf ?
Arthur Walaseks' Exporters

Searching for great and free plugins?
www.sgross.com by Steffen Gross

You are searching for tutorials? More video- and text-tutorials can be found here:
Tutorial section of PW3d

You want to make your own video tutorial?
Recommended Tools and Step By Step Instructions

"R M B" stands for "Right Mouse Button"!

#42 NancyGormezano

NancyGormezano

    Runs With Scissors

  • Film
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7686 posts
  • Nancy Gormezano
  • Cupertino, CA
  • Windows
  • Contests Won:**

Posted 02 November 2015 - 01:48 PM

Hi Nancy -

 

I just chose OpenGL over OpenGL3 and the crash still persists.

fooey.

 

I don't know how macs work when you use A:M under the windows OS (which windows OS by the way?). But do you have to install the windows version as well as the mac version on your system? And do you install the 32 bit or the 64 bit?

 

Do you know if A:M 18n (mac version? windows version? ) worked before you updated your system via Apple's App Store a few days ago?

 

Do any other A:M versions run or not run currently under windows os, or mac os



#43 cribbidaj

cribbidaj

    Wayfarer

  • Craftsman/Mentor
  • PipPipPipPipPip
  • 275 posts
  • Chris Walters
  • Nashville, TN
  • current
  • Mac/Win

Posted 02 November 2015 - 02:03 PM

I'm not using Windows.  I'm running A:M on a Mac in OS 10.9.5

 

I just submitted a bug report.

 

Thanks for all your help.



#44 NancyGormezano

NancyGormezano

    Runs With Scissors

  • Film
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7686 posts
  • Nancy Gormezano
  • Cupertino, CA
  • Windows
  • Contests Won:**

Posted 02 November 2015 - 02:15 PM

I'm not using Windows.  I'm running A:M on a Mac in OS 10.9.5

 

I just submitted a bug report.

 

Thanks for all your help.

oh I see. I am ignorant about Macs - but there seems to be a problem with macs and graphic cards (nvidia especially). I have no idea if this is your problem. Glad you put in bug report.

 

See this comment



#45 nemyax

nemyax

  • *A:M User*
  • PipPipPipPipPip
  • 343 posts
  • - - - -

Posted 03 November 2015 - 12:51 AM

I've finally reported this old version 18 issue: http://www.hash.com/...iew.php?id=6631

Posting here just to bring some additional attention to it.



#46 largento

largento

    Animated Puppet Parodist

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3586 posts
  • Mark R. Largent
  • Dallas, Texas
  • current
  • Macintosh
  • Programmer:NO
  • Contests Won:*

Posted 04 November 2015 - 08:44 AM

I can confirm this problem on the Mac. I just bought a new iMac and since the new subscription for A:M doesn't have old settings to go by, I'm unable to make changes in the options window. Going to try an earlier version and see if that works.



#47 largento

largento

    Animated Puppet Parodist

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3586 posts
  • Mark R. Largent
  • Dallas, Texas
  • current
  • Macintosh
  • Programmer:NO
  • Contests Won:*

Posted 04 November 2015 - 09:37 AM

Okay, someone may want to try this workaround to confirm:

 

1) Download and install the Intel mac version (not the SSE4 version.)

 

2) Make all of your settings.

 

3) Download and install the SSE4 version.

 

4) Never open the options or customize window. :-)

 

I did this with Version M. But the problem is there on the SSE4 version, too. I'm running El Capitan.

 

[EDIT] This should work with Version N. I installed the Intel version of N over my SSE4 M version and then installed the SSE4 N version over that and all my settings have remained and as long as I don't open those control panels, I'm good to go. It's going to be an issue with doing any lathing, but at least it works for the basics.



#48 Fuchur

Fuchur

    PatchWorker

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4857 posts
  • Gerald Zum Gahr
  • Karlsruhe, Germany
  • current
  • Windows

Posted 04 November 2015 - 12:31 PM

Is there a registery of some kind on the Mac? If yes, you can very likely change any of the settings there... at least on the windows-version you can do that.

See you
*Fuchur*


"I know, that I don't know."
See my projects, tutorials, reviews and join the German Animation:Master-Community at
www.PatchWork3d.de

Name: Gerald Zum Gahr, alias Fuchur
What stands "Fuchur" for?

Do want to see my favorite A:M-images?
Best of A:M collected by Gerald Zum Gahr

Searching for a *.X-Exporter(DirectX) or a *.dts-Exporter(Torque) for A:M?
Exporter Page

And how can I export to *.FBX-files or other 3d- / game-engines?
FBX-Pipeline to Unity3d / DirectX-Pipeline to Quest3d

Need more converters? *.obj OBJ), *.lwo , *.act or *.dxf ?
Arthur Walaseks' Exporters

Searching for great and free plugins?
www.sgross.com by Steffen Gross

You are searching for tutorials? More video- and text-tutorials can be found here:
Tutorial section of PW3d

You want to make your own video tutorial?
Recommended Tools and Step By Step Instructions

"R M B" stands for "Right Mouse Button"!

#49 largento

largento

    Animated Puppet Parodist

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3586 posts
  • Mark R. Largent
  • Dallas, Texas
  • current
  • Macintosh
  • Programmer:NO
  • Contests Won:*

Posted 04 November 2015 - 01:43 PM

There's a "preference file," Gerald, but I'm not sure how easy it would be to understand what is what to modify it. At the very least, you'd have to quit A:M, make the change and then reopen A:M.

 

[EDIT] At least I've narrowed it down to being a problem only with the SSE4 versions.







Also tagged with one or more of these keywords: Download, Software Update, Animation Master, Get it now!

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users