Jump to content


Photo

Timing

Resolved render timing

  • Please log in to reply
4 replies to this topic

#1 Andrew

Andrew

    New User

  • *A:M User*
  • Pip
  • 21 posts
  • Andrew Simpson
  • Brisbane, Australia
  • current
  • Macintosh

Posted 31 December 2015 - 04:19 AM

Hello Everyone,

I am having a problem with rendering a scene at the correct length. I have a scene that is 14400 frames long, and I am rendering at 24 Frames Per Second. But I am getting a file that is a little over 8 minutes long when it should be 10 minutes.
Does anyone have any experience in which render options I should choose to have the file rendered at the correct length? I have a clock in this scene, so it is important that it is the right length.
 
Thanks in advance to all those who help.
Andrew
 

 

Attached Files



#2 jimd

jimd

    Prolific

  • Craftsman/Mentor
  • PipPipPipPipPipPipPip
  • 549 posts
  • ct
  • Macintosh

Posted 31 December 2015 - 05:27 AM

Hi

check to make sure you are exportng the correct range of your timeline (just incase )

and try using animation as your export setting ( you can adjust your frames per sec to match )

Attached Files



#3 Simon Edmondson

Simon Edmondson

    Filmmaker

  • *A:M User*
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2505 posts
  • East Anglia UK
  • Macintosh
  • Programmer:NO

Posted 31 December 2015 - 06:34 AM

Andrew

I am no expert here but, it might be worth checking  what is  selected within Tools/options ?

AM tends to default to 30fps so, unless you have  specifically  chosen otherwise, it will revert to that,

Especially if the "use this dialogue" option is also selected within the render tag ?

 

If you do use the 'Animation' option, the  file size will be rather large as that is an uncompressed format.

Personally I use H264 because its a good compression without a great loss of quality.

 

Which version of AM are you using ?

regards

simon


"Making Mistakes is the key to making progress"
Daniel C Dennett philosopher

#4 robcat2075

robcat2075

    persistent smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 24049 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • current
  • Windows
  • Programmer:NO

Posted 31 December 2015 - 07:28 AM

The difference between 8 minutes and 10 minutes is indeed the difference between 30fps and 24 fps for 14,400 frames. (btw, thats a lot to be rendering in one scene from A:M)

 

In A:M proper, the fps setting is found in the properties of the Project in the PWS.  The compression settings will not overrule the PRJ setting.

 

Attached File  fps.JPG   36.98KB   0 downloads

 

That is something you typically set before you begin keyframing as all keyframes are identified internally as a certain amount of time from the start rather than a certain number of frames. Changing FPS to 24 now will not make the animation run longer.

 

If you are wanting to rerender, it is possible to stretch your animation out to run for 10 minutes.

 

Change the FPS setting in the PWS to 24

-Change your times display from Frames to SMPTE in the Units Panel.

-Find or make a keyframe at exactly 8 minutes in the time line

-Select all the Keyframes in the timeline

-Drag the right edge of the bounding box until the key frame that was at 8 minutes is now precisely on 10 minutes.  This stretches all keyframes proportionately.

-Save under a new filename and render.

 

 

If you don't want to re-render and have Quicktime Pro you can

 

-export the animation from QT Pro as an image sequence at 30fps (in QT the fps setting DOES govern the result),

-then import it back into QT Pro as an image sequence with 24 FPS chosen as the import speed,

-then export again as a QT file with 24 FPS chosen in the compression settings.

Of course there will be some loss of quality from all the  recompression

 

i believe it is also possible to do this maneuver in A:M:

 

In 32-bit A:M (Windows only, on Mac this doesn't matter), Set FPS in the PRJ to 30. 

Import the animation to the Images folder.

RMB and do "Save Animation As..."

Click on the ... button to set a file type of JPG or TGA

Click OK, to export

 

Close and reopen 32-bit A:M

Set  FPS in the PWS to 24

Import the image sequence,

RMB "Save Animation as"

Click on the ... button to choose Quicktime as the export type.

Click on the Compression button to choose the codec and compression settings.

Export to Quicktime file.

 

 

 

 


Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT (1700 GMT)

Watch the 2017 "Summer Memories" Image Contest Awards

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!


#5 Andrew

Andrew

    New User

  • *A:M User*
  • Pip
  • 21 posts
  • Andrew Simpson
  • Brisbane, Australia
  • current
  • Macintosh

Posted 31 December 2015 - 08:39 PM

Thanks Robert,

You hit the nail on the head. I had not changed the FPS for the project. I had created the project before I changed the software default FPS to 24.
 
Yes, it is a big scene, but it is just a simple clock, and it makes sense to render it all at once. This is also the reason the timing is crucial.
 
Thanks for your input everyone it was all helpful.
Andrew






Also tagged with one or more of these keywords: Resolved, render, timing

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users