Jump to content


Photo
- - - - -

mtpeak, I need shadow passes


  • Please log in to reply
11 replies to this topic

#1 robcat2075

robcat2075

    occasional smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 23982 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • other
  • Windows
  • Programmer:NO

Posted 12 November 2010 - 04:23 PM

Mark, I guess I'll need a shadow pass to go with the bus movies you gave me. It will look like pure white with the shadow of the bus passing through but without the bus visible. thanks

Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT (1700 GMT)

Watch the 2017 "Summer Memories" Image Contest Awards

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!


#2 robcat2075

robcat2075

    occasional smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 23982 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • other
  • Windows
  • Programmer:NO

Posted 20 December 2010 - 01:20 PM

Any daylight on this one?

Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT (1700 GMT)

Watch the 2017 "Summer Memories" Image Contest Awards

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!


#3 mtpeak2

mtpeak2

    Not a Master

  • Film
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5767 posts
  • Mark Skodacek
  • New Jersey
  • Windows

Posted 30 January 2011 - 07:09 PM

Sorry Robert, I missed this. There is an issue with just a shadow pass, the AO does not render. Maybe I could use the fake AO.
2008 Rig updated 04/20/2011

#4 robcat2075

robcat2075

    occasional smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 23982 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • other
  • Windows
  • Programmer:NO

Posted 31 January 2011 - 08:14 AM

Sorry Robert, I missed this. There is an issue with just a shadow pass, the AO does not render. Maybe I could use the fake AO.


How about rendering normal to EXR and getting the AO buffer?

Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT (1700 GMT)

Watch the 2017 "Summer Memories" Image Contest Awards

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!


#5 robcat2075

robcat2075

    occasional smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 23982 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • other
  • Windows
  • Programmer:NO

Posted 05 March 2011 - 09:26 AM

Mark, here's what to do: -replace the Land Proxy with one that does not have holes for the manhole or storm sewer -turn OFF the garbage Can, Park bench, sign, manhole, and Storm drain - got to render and load this Preset -you'll need to set the appropriate frame range, filename and destination -render Hopefully the buses were animated far enough to get the shadows off screen. Attached File  EXRShadowBufferRender.pre   5.35KB   77 downloads This will render to EXR with Occlusion and Shadow buffers which i can extract in an A:M Composite ShadowPassParts.JPG thanks!

Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT (1700 GMT)

Watch the 2017 "Summer Memories" Image Contest Awards

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!


#6 mtpeak2

mtpeak2

    Not a Master

  • Film
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5767 posts
  • Mark Skodacek
  • New Jersey
  • Windows

Posted 05 March 2011 - 03:55 PM

Well, I didn't have the bus animated far enough for no shadow, oops. So, I'll rerender the color alpha and then I'll render the shadow pass. I am having issues with the group properties on the bus. It is not rendering the same as it did when I rendered it the first time, I think I rendered it in v13. I don't know where the problem is.
2008 Rig updated 04/20/2011

#7 robcat2075

robcat2075

    occasional smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 23982 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • other
  • Windows
  • Programmer:NO

Posted 05 March 2011 - 04:30 PM

I am having issues with the group properties on the bus.


Try changing them to a material on the group. There's an RMB thing now to create material out of group parameters.

Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT (1700 GMT)

Watch the 2017 "Summer Memories" Image Contest Awards

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!


#8 mtpeak2

mtpeak2

    Not a Master

  • Film
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5767 posts
  • Mark Skodacek
  • New Jersey
  • Windows

Posted 05 March 2011 - 05:04 PM

I thought I had already fixed the group thing, and I did, but there was something else going on. I think I got it though. The problem is the options for the ground. I had it set to "Receive Shadows" and "Shadow Only" set to ON, so the bus was the only thing rendering. This worked in v13 and the ground still casted "Occlusion" onto the bus, but in v16 this does not happen and thought it was a group problem. So I turned the "Shadow Only" option OFF and set the transparency to 100% on the ground and now it renders the way it did before. I'm not sure how it's suppose to work, so I don't know if something is broken now or before.
2008 Rig updated 04/20/2011

#9 robcat2075

robcat2075

    occasional smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 23982 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • other
  • Windows
  • Programmer:NO

Posted 05 March 2011 - 06:02 PM

My test was in V16 For the EXR pass I had the ground set as if it were a regular render, none of the shadows only stuff. For the bus, render a regular TGA pass with no alpha with the bus and the background in the render, and another one with Alpha ON that is just the bus and i can take the alpha from that to mask out everything but the bus form the regular pass.

Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT (1700 GMT)

Watch the 2017 "Summer Memories" Image Contest Awards

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!


#10 mtpeak2

mtpeak2

    Not a Master

  • Film
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5767 posts
  • Mark Skodacek
  • New Jersey
  • Windows

Posted 05 March 2011 - 06:23 PM

For the EXR shadow pass, I know I don't need the shadow only stuff. I am already rendering a color alpha pass, which I need the occlusion of the ground casted on the bus, but the ground to not render. Your way I would need 3 renders, my way should only needs 2. Don't forget, I have 2 bus animations, that would be 6 renders I would need to do.
2008 Rig updated 04/20/2011

#11 mtpeak2

mtpeak2

    Not a Master

  • Film
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5767 posts
  • Mark Skodacek
  • New Jersey
  • Windows

Posted 06 March 2011 - 11:18 AM

Robert, I sent you an e-mail with dropbox links to the files. If these do not work for you, I'll send you the project files.
2008 Rig updated 04/20/2011

#12 robcat2075

robcat2075

    occasional smarty-pants

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 23982 posts
  • Robert Holmén
  • *Moderator*
  • Dallas, Texas
  • other
  • Windows
  • Programmer:NO

Posted 09 March 2011 - 03:07 PM

thanks, Mark, those will work well!

Robert Holmén
------

Got an A:M question? Come to Live Answer Time.   Saturdays, Noon CDT (1700 GMT)

Watch the 2017 "Summer Memories" Image Contest Awards

 

My tutorials All my most beloved tutorials in one convenient location. Except for the ones I've forgotten about.
 
this is only a ... my gallery of A:M tests

87,848 pushed!: the #1 heavy push on Youtube

Big thanks to... Roger (again!), Shelton (it's huge!), NancyGormezano, Roger, cribbidaj, thefreshestever, Tom, Dalemation, Simon Edmondson, thejobe, Rob_T (2 more x), agep (again!), itsjustme, jason1025(+1), dblhelix (+1),markw, Roger (3x!), mouseman (x 2!), Xtaz, agep, Gerry, thefreshestever, dblhelix (twice!), jason1025, Luuk Steitner, PDM, Rob_T and Dhar!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users