Jump to content


Photo

VC++ and A:M version compatibility


  • Please log in to reply
3 replies to this topic

#1 nemyax

nemyax

  • *A:M User*
  • PipPipPipPipPip
  • 336 posts
  • - - - -

Posted 13 July 2014 - 09:45 AM

Can Visual C++ 2010 Express be used for A:M plugin development?
Can the V18 SDK be used for making V17 plugins? (Unfortunately, V18 is unusable on my system.)

#2 Fuchur

Fuchur

    PatchWorker

  • Hash Fellow
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4834 posts
  • Gerald Zum Gahr
  • Karlsruhe, Germany
  • v18
  • Windows

Posted 13 July 2014 - 10:20 AM

As far as I know Express does not allow MFC code to be used, which is needed if I am not wrong.

BUT that does not have to be true anymore, based on this article: http://www.codeproje...isual-C-Express

 

If you can use mfc with that, you should be able to create plugins with it. v18 mainly introduces OpenGL 3.0... so as long as you do not use these functionalities it should be able to be used or at least should be very easy to be transfered afterwards.

 

See you

*Fuchur*


"I know, that I don't know."
See my projects, tutorials, reviews and join the German Animation:Master-Community at
www.PatchWork3d.de

Name: Gerald Zum Gahr, alias Fuchur
What stands "Fuchur" for?

Do want to see my favorite A:M-images?
Best of A:M collected by Gerald Zum Gahr

Searching for a *.X-Exporter(DirectX) or a *.dts-Exporter(Torque) for A:M?
Exporter Page

And how can I export to *.FBX-files or other 3d- / game-engines?
FBX-Pipeline to Unity3d / DirectX-Pipeline to Quest3d

Need more converters? *.obj OBJ), *.lwo , *.act or *.dxf ?
Arthur Walaseks' Exporters

Searching for great and free plugins?
www.sgross.com by Steffen Gross

You are searching for tutorials? More video- and text-tutorials can be found here:
Tutorial section of PW3d

You want to make your own video tutorial?
Recommended Tools and Step By Step Instructions

"R M B" stands for "Right Mouse Button"!

#3 nemyax

nemyax

  • *A:M User*
  • PipPipPipPipPip
  • 336 posts
  • - - - -

Posted 03 November 2016 - 02:07 AM

Which version of Visual Studio is used for the development of A:M 19.0?



#4 yoda64

yoda64

    Prolific

  • Developer
  • PipPipPipPipPipPipPip
  • 726 posts
  • Steffen Gross
  • Goeppingen,Germany
  • Windows
  • Programmer:Yes

Posted 06 November 2016 - 03:07 AM

Visual Studio 2015 (recommended also for plugins now) + Intel 2016


Kind Regards
Steffen

http://www.sgross.com/plugins/





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users